import re
regex = re.compile(r"^([^.]*\.)|\.", flags=re.MULTILINE)
test_str = "59.34343.23"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)