re = /(?<=\.)[a-z0-9]+(?=\/")/
str = 'Miscellaneous="example1.com/"
Miscellaneous="example2.gov.au/"
Miscellaneous="example3.co.uk/" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end