using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^4([0-9AB]{1})([0-9a-zA-Z]{93})$";
string input = @"4AfUP827TeRZ1cck3tZThgZbRCEwBrpcJTkA1LCiyFVuMH4b5y59bKMZHGb9y58K3gSjWDCBsB4RkGsGDhsmMG5R2qmbLeW
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}