re = /^4([0-9AB]{1})([0-9a-zA-Z]{93})$/i
str = '4AfUP827TeRZ1cck3tZThgZbRCEwBrpcJTkA1LCiyFVuMH4b5y59bKMZHGb9y58K3gSjWDCBsB4RkGsGDhsmMG5R2qmbLeW
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end