package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^4([0-9AB]{1})([0-9a-zA-Z]{93})$`)
var str = `4AfUP827TeRZ1cck3tZThgZbRCEwBrpcJTkA1LCiyFVuMH4b5y59bKMZHGb9y58K3gSjWDCBsB4RkGsGDhsmMG5R2qmbLeW
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}