#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0000).*"
Local $sString = "asdf" & @CRLF & _
"0asdf" & @CRLF & _
"00asdfa" & @CRLF & _
"000asdfasdf" & @CRLF & _
"0000asdf" & @CRLF & _
"a0000adf" & @CRLF & _
"asdfasdf000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")