$re = '/^(?!0000).*/m';
$str = 'asdf
0asdf
00asdfa
000asdfasdf
0000asdf
a0000adf
asdfasdf000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);