re = /^(?!0000).*/m
str = 'asdf
0asdf
00asdfa
000asdfasdf
0000asdf
a0000adf
asdfasdf000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end