import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?=[^\\{]+\\})";
final String string = "{\n"
+ " this is a line,\n"
+ " this = another line,\n"
+ " this is the third line!\n"
+ "this is, indeed, another line\n"
+ "},\n"
+ "round two: {\n"
+ "we're now on the second pair of brackets,\n"
+ " and this is the final line.\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}