$re = '/.+(?=[^{]+})/m';
$str = '{
this is a line,
this = another line,
this is the third line!
this is, indeed, another line
},
round two: {
we\'re now on the second pair of brackets,
and this is the final line.
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);