re = /.+(?=[^{]+})/m
str = '{
this is a line,
this = another line,
this is the third line!
this is, indeed, another line
},
round two: {
we\'re now on the second pair of brackets,
and this is the final line.
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end