#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b(?:19\d{2}|20[0-4]\d|2050)\b)(?!.*(?1))"
Local $sString = "ACB 01900 X1911D 1910 1955-2011 3424 2135 1934 foobar" & @CRLF & _
"ACB 01900 X1911D 1910 1955-2011 3424 2035 2054 foobar" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")