$re = '/(\b(?:19\d{2}|20[0-4]\d|2050)\b)(?!.*(?1))/m';
$str = 'ACB 01900 X1911D 1910 1955-2011 3424 2135 1934 foobar
ACB 01900 X1911D 1910 1955-2011 3424 2035 2054 foobar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);