use strict;
my $str = 'ACB 01900 X1911D 1910 1955-2011 3424 2135 1934 foobar
ACB 01900 X1911D 1910 1955-2011 3424 2035 2054 foobar
';
my $regex = qr/(\b(?:19\d{2}|20[0-4]\d|2050)\b)(?!.*(?1))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}