using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+([\u0900-\u097F]*)\s+([०-९]{2}).([०-९]{4})\s+\(कौमुदीधातुः-\s([०-९]{4})\)[\s\S]*(परस्मैपदी|आत्मनेपदी)\s+(अकर्मकः|सकर्मकः)";
string input = @"
इ
०२.००४०
(कौमुदीधातुः- १०४५)
इण्
गतौ
(अदादिः
परस्मैपदी
सकर्मकः
अनिट्
)
कर्तरि
भावकर्मणोः
सन्नन्ते
णिजन्ते
यङन्ते
कृदन्ते
उपसर्गार्थाः
उपसर्गार्थचन्द्रिका
प्रयोगाः
Info
कर्तरि लट्लकारः (परस्मैपदम्)
एति
इतः
यन्ति
एषि
इथः
इथ
एमि
इवः
इमः
कर्तरि लिट्लकारः (परस्मैपदम्)
इयाय
ईयतुः
ईयुः
इयेथ, इययिथ
ईयथुः
ईय
इयाय, इयय
ईयिव
ईयिम
कर्तरि लुट्लकारः (परस्मैपदम्)
एता
एतारौ
एतारः
एतासि
एतास्थः
एतास्थ
एतास्मि
एतास्वः
एतास्मः
कर्तरि लृट्लकारः (परस्मैपदम्)
एष्यति
एष्यतः
एष्यन्ति
एष्यसि
एष्यथः
एष्यथ
एष्यामि
एष्यावः
एष्यामः
कर्तरि लोट्लकारः (परस्मैपदम्)
एतु, इतात्
इताम्
यन्तु
इहि, इतात्
इतम्
इत
अयानि
अयाव
अयाम
कर्तरि लङ्लकारः (परस्मैपदम्)
ऐत्
ऐताम्
आयन्
ऐः
ऐतम्
ऐत
आयम्
ऐव
ऐम
कर्तरि विधिलिङ्लकारः (परस्मैपदम्)
इयात्
इयाताम्
इयुः
इयाः
इयातम्
इयात
इयाम्
इयाव
इयाम
कर्तरि आशीर्लिङ्लकारः (परस्मैपदम्)
ईयात्
ईयास्ताम्
ईयासुः
ईयाः
ईयास्तम्
ईयास्त
ईयासम्
ईयास्व
ईयास्म
कर्तरि लुङ्लकारः (परस्मैपदम्)
अगात्
अगाताम्
अगुः
अगाः
अगातम्
अगात
अगाम्
अगाव
अगाम
कर्तरि लृङ्लकारः (परस्मैपदम्)
ऐष्यत्
ऐष्यताम्
ऐष्यन्
ऐष्यः
ऐष्यतम्
ऐष्यत
ऐष्यम्
ऐष्याव
ऐष्याम
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}