import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+([\\u0900-\\u097F]*)\\s+([०-९]{2}).([०-९]{4})\\s+\\(कौमुदीधातुः-\\s([०-९]{4})\\)[\\s\\S]*(परस्मैपदी|आत्मनेपदी)\\s+(अकर्मकः|सकर्मकः)";
final String string = "\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इ\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ०२.००४० \n"
+ " (कौमुदीधातुः- १०४५)\n"
+ " इण् \n"
+ " गतौ\n"
+ " \n"
+ " \n"
+ " (अदादिः \n"
+ " परस्मैपदी \n"
+ " \n"
+ " सकर्मकः \n"
+ " अनिट् \n"
+ " \n"
+ " \n"
+ " ) \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " कर्तरि\n"
+ " \n\n"
+ " \n"
+ " भावकर्मणोः\n"
+ " \n\n"
+ " \n"
+ " सन्नन्ते\n"
+ " \n\n"
+ " \n"
+ " णिजन्ते\n"
+ " \n\n"
+ " \n"
+ " यङन्ते\n"
+ " \n\n"
+ " \n"
+ " कृदन्ते\n"
+ " \n\n"
+ " \n"
+ " उपसर्गार्थाः\n"
+ " \n\n"
+ " \n"
+ " उपसर्गार्थचन्द्रिका\n"
+ " \n\n"
+ " \n"
+ " प्रयोगाः\n"
+ " \n\n"
+ " \n"
+ " Info\n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n\n\n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लट्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एति\n"
+ " इतः\n"
+ " यन्ति\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एषि\n"
+ " इथः\n"
+ " इथ\n"
+ " \n"
+ " \n"
+ " \n"
+ " एमि\n"
+ " इवः\n"
+ " इमः\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लिट्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इयाय\n"
+ " ईयतुः\n"
+ " ईयुः\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इयेथ, इययिथ\n"
+ " ईयथुः\n"
+ " ईय\n"
+ " \n"
+ " \n"
+ " \n"
+ " इयाय, इयय\n"
+ " ईयिव\n"
+ " ईयिम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लुट्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एता\n"
+ " एतारौ\n"
+ " एतारः\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एतासि\n"
+ " एतास्थः\n"
+ " एतास्थ\n"
+ " \n"
+ " \n"
+ " \n"
+ " एतास्मि\n"
+ " एतास्वः\n"
+ " एतास्मः\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लृट्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एष्यति\n"
+ " एष्यतः\n"
+ " एष्यन्ति\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एष्यसि\n"
+ " एष्यथः\n"
+ " एष्यथ\n"
+ " \n"
+ " \n"
+ " \n"
+ " एष्यामि\n"
+ " एष्यावः\n"
+ " एष्यामः\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लोट्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " एतु, इतात्\n"
+ " इताम्\n"
+ " यन्तु\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इहि, इतात्\n"
+ " इतम्\n"
+ " इत\n"
+ " \n"
+ " \n"
+ " \n"
+ " अयानि\n"
+ " अयाव\n"
+ " अयाम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लङ्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ऐत्\n"
+ " ऐताम्\n"
+ " आयन्\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ऐः\n"
+ " ऐतम्\n"
+ " ऐत\n"
+ " \n"
+ " \n"
+ " \n"
+ " आयम्\n"
+ " ऐव\n"
+ " ऐम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि विधिलिङ्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इयात्\n"
+ " इयाताम्\n"
+ " इयुः\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " इयाः\n"
+ " इयातम्\n"
+ " इयात\n"
+ " \n"
+ " \n"
+ " \n"
+ " इयाम्\n"
+ " इयाव\n"
+ " इयाम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि आशीर्लिङ्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ईयात्\n"
+ " ईयास्ताम्\n"
+ " ईयासुः\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ईयाः\n"
+ " ईयास्तम्\n"
+ " ईयास्त\n"
+ " \n"
+ " \n"
+ " \n"
+ " ईयासम्\n"
+ " ईयास्व\n"
+ " ईयास्म\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लुङ्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " अगात्\n"
+ " अगाताम्\n"
+ " अगुः\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " अगाः\n"
+ " अगातम्\n"
+ " अगात\n"
+ " \n"
+ " \n"
+ " \n"
+ " अगाम्\n"
+ " अगाव\n"
+ " अगाम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " कर्तरि लृङ्लकारः (परस्मैपदम्)\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ऐष्यत्\n"
+ " ऐष्यताम्\n"
+ " ऐष्यन्\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ऐष्यः\n"
+ " ऐष्यतम्\n"
+ " ऐष्यत\n"
+ " \n"
+ " \n"
+ " \n"
+ " ऐष्यम्\n"
+ " ऐष्याव\n"
+ " ऐष्याम\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n\n\n\n\n\n\n\n"
+ " \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}