using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-~]\s(\d*)?-?(\d*)";
string input = @"- 1 / something / something else / ...
~ 2 / another something / something else / ... / ...
- 3-4 / thing / ...
-~ 5-6 / ... / ... / ... / ... / ...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}