re = /[-~]\s(\d*)?-?(\d*)/m
str = '- 1 / something / something else / ...
~ 2 / another something / something else / ... / ...
- 3-4 / thing / ...
-~ 5-6 / ... / ... / ... / ... / ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end