$re = '/[-~]\s(\d*)?-?(\d*)/m';
$str = '- 1 / something / something else / ...
~ 2 / another something / something else / ... / ...
- 3-4 / thing / ...
-~ 5-6 / ... / ... / ... / ... / ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);