#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ'.]*\s)\d*(\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)*,)*\d*(\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)+,\s([\d]{5})\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']+"
Local $sString = "Apt. 120, 9 Quai de Caumartin, 21305 Tourcoing" & @CRLF & _
"8 étage, 229 Boulevard de Caumartin, 41224 Clichy" & @CRLF & _
"8116 Boulevard Pierre Charron, 51703 Bordeaux" & @CRLF & _
"9 Quai de Caumartin, 21305 Tourcoing" & @CRLF & _
"Apt. 901, 8431 Boulevard Vaneau, 85330 Mérignac" & @CRLF & _
"314 Passage de la Férronnerie, 76818 Villejuif" & @CRLF & _
"1 étage, 6645 Avenue des Grands Augustins, 47851 Lyon" & @CRLF & _
"Apt. 889, 301 Place Adolphe Mille, 04320 Issy-les-Moulineaux" & @CRLF & _
"Apt. 470, 147 Allée, Voie des Grands Augustins, 37097 Asnières-sur-Seine" & @CRLF & _
"Apt. 356, 1 Allée, Voie de l'Abbaye, 83865 Champigny-sur-Marne" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")