import re
regex = re.compile(r"(([a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ'.]*\s)\d*(\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)*,)*\d*(\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)+,\s([\d]{5})\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']+", flags=re.MULTILINE)
test_str = ("Apt. 120, 9 Quai de Caumartin, 21305 Tourcoing\n"
"8 étage, 229 Boulevard de Caumartin, 41224 Clichy\n"
"8116 Boulevard Pierre Charron, 51703 Bordeaux\n"
"9 Quai de Caumartin, 21305 Tourcoing\n"
"Apt. 901, 8431 Boulevard Vaneau, 85330 Mérignac\n"
"314 Passage de la Férronnerie, 76818 Villejuif\n"
"1 étage, 6645 Avenue des Grands Augustins, 47851 Lyon\n"
"Apt. 889, 301 Place Adolphe Mille, 04320 Issy-les-Moulineaux\n"
"Apt. 470, 147 Allée, Voie des Grands Augustins, 37097 Asnières-sur-Seine\n"
"Apt. 356, 1 Allée, Voie de l'Abbaye, 83865 Champigny-sur-Marne\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")