import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ'.]*\\s)\\d*(\\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)*,)*\\d*(\\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']*)+,\\s([\\d]{5})\\s[a-zA-Z-éÉèÈàÀùÙâÂêÊîÎôÔûÛïÏëËüÜçÇæœ']+";
final String string = "Apt. 120, 9 Quai de Caumartin, 21305 Tourcoing\n"
+ "8 étage, 229 Boulevard de Caumartin, 41224 Clichy\n"
+ "8116 Boulevard Pierre Charron, 51703 Bordeaux\n"
+ "9 Quai de Caumartin, 21305 Tourcoing\n"
+ "Apt. 901, 8431 Boulevard Vaneau, 85330 Mérignac\n"
+ "314 Passage de la Férronnerie, 76818 Villejuif\n"
+ "1 étage, 6645 Avenue des Grands Augustins, 47851 Lyon\n"
+ "Apt. 889, 301 Place Adolphe Mille, 04320 Issy-les-Moulineaux\n"
+ "Apt. 470, 147 Allée, Voie des Grands Augustins, 37097 Asnières-sur-Seine\n"
+ "Apt. 356, 1 Allée, Voie de l'Abbaye, 83865 Champigny-sur-Marne\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}