#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)sip:[0-9]*@((\b((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4}\b)|((([a-zA-Z]{1})|([a-zA-Z]{1}[a-zA-Z]{1})|([a-zA-Z]{1}[0-9]{1})|([0-9]{1}[a-zA-Z]{1})|([a-zA-Z0-9][a-zA-Z0-9-_]{1,61}[a-zA-Z0-9]))\.([a-zA-Z]{2,6}|[a-zA-Z0-9-]{2,30}\.[a-zA-Z]{2,3})))" & @CRLF & _
""
Local $sString = "sip:4563214567@example.com" & @CRLF & _
"sip:4563214567@example.co.uk" & @CRLF & _
"sip:4563214567@192.168.1.123" & @CRLF & _
"sip:4563214567@192.168.1.444" & @CRLF & _
"" & @CRLF & _
"sip:4563214567@192.168.1.1234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sip:4563214567@XX.XX.XX.XX -> XX = IP address" & @CRLF & _
"" & @CRLF & _
"sip:4563214567@XX.XX.XX.XX -> XX = IP address" & @CRLF & _
"" & @CRLF & _
"sip:4563214567example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")