re = /sip:[0-9]*@((\b((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4}\b)|((([a-zA-Z]{1})|([a-zA-Z]{1}[a-zA-Z]{1})|([a-zA-Z]{1}[0-9]{1})|([0-9]{1}[a-zA-Z]{1})|([a-zA-Z0-9][a-zA-Z0-9-_]{1,61}[a-zA-Z0-9]))\.([a-zA-Z]{2,6}|[a-zA-Z0-9-]{2,30}\.[a-zA-Z]{2,3})))
/m
str = 'sip:4563214567@example.com
sip:4563214567@example.co.uk
sip:4563214567@192.168.1.123
sip:4563214567@192.168.1.444
sip:4563214567@192.168.1.1234
sip:4563214567@XX.XX.XX.XX -> XX = IP address
sip:4563214567@XX.XX.XX.XX -> XX = IP address
sip:4563214567example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end