using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sip:[0-9]*@((\b((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4}\b)|((([a-zA-Z]{1})|([a-zA-Z]{1}[a-zA-Z]{1})|([a-zA-Z]{1}[0-9]{1})|([0-9]{1}[a-zA-Z]{1})|([a-zA-Z0-9][a-zA-Z0-9-_]{1,61}[a-zA-Z0-9]))\.([a-zA-Z]{2,6}|[a-zA-Z0-9-]{2,30}\.[a-zA-Z]{2,3})))
";
string input = @"sip:4563214567@example.com
sip:4563214567@example.co.uk
sip:4563214567@192.168.1.123
sip:4563214567@192.168.1.444
sip:4563214567@192.168.1.1234
sip:4563214567@XX.XX.XX.XX -> XX = IP address
sip:4563214567@XX.XX.XX.XX -> XX = IP address
sip:4563214567example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}