#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{3,20}$)[a-z0-9]+([_][a-z0-9]+)*$"
Local $sString = "a_123" & @CRLF & _
"1_1" & @CRLF & _
"amit12343" & @CRLF & _
"12ami" & @CRLF & _
"a_457_h" & @CRLF & _
"a__a" & @CRLF & _
"a_______0_" & @CRLF & _
"_0_sd" & @CRLF & _
"0_0" & @CRLF & _
"12" & @CRLF & _
"a1" & @CRLF & _
"123456789012345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")