use strict;
my $str = 'a_123
1_1
amit12343
12ami
a_457_h
a__a
a_______0_
_0_sd
0_0
12
a1
123456789012345678901';
my $regex = qr/^(?=.{3,20}$)[a-z0-9]+([_][a-z0-9]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}