re = /^(?=.{3,20}$)[a-z0-9]+([_][a-z0-9]+)*$/m
str = 'a_123
1_1
amit12343
12ami
a_457_h
a__a
a_______0_
_0_sd
0_0
12
a1
123456789012345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end