re = /\h*([,\h])(?1)*/m
str = 'first , second ,, , , third, ,fourth suffix ,, more'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result