package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^S[0-9]+$`)
var str = `S9285829
T295820
S2959x
S2959
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}