$re = '/^S[0-9]+$/m';
$str = 'S9285829
T295820
S2959x
S2959
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);