const regex = /^S[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^S[0-9]+$', 'gm')
const str = `S9285829
T295820
S2959x
S2959
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}