import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h+[\\{\\}](?=\\h*\\R)(*SKIP)(*FAIL)|[\\{\\}]";
final String string = " Menu \"MenuName\"\n"
+ " {\n"
+ " Menu \"SubMenuName\"\n"
+ " {\n"
+ " Option \"OptionName\" \"Command\"\n"
+ " Option \"OptionName\" \"Command\"\n"
+ " }\n"
+ " }\n"
+ "// This is a comment line\n"
+ "// [ curly brackets in comment lines are made square so they don't get counted as balancing\n\n\n"
+ " Menu \"MenuName\"{\n"
+ " Menu \"SubMenuName\"\n"
+ " {\n"
+ " Option \"OptionName\" \"Command\"\n"
+ " Option \"OptionName\" \"Command\" }\n"
+ " }Menu \"That bracket would be wrong since the line should end afterwards.\n"
+ " { //this would also be wrong\n"
+ "// Nothing should ever follow a bracket except a End Of Line character.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}