import re
regex = re.compile(r"^\h+[{}](?=\h*\R)(*SKIP)(*FAIL)|[{}]", flags=re.MULTILINE)
test_str = (" Menu \"MenuName\"\n"
" {\n"
" Menu \"SubMenuName\"\n"
" {\n"
" Option \"OptionName\" \"Command\"\n"
" Option \"OptionName\" \"Command\"\n"
" }\n"
" }\n"
"// This is a comment line\n"
"// [ curly brackets in comment lines are made square so they don't get counted as balancing\n\n\n"
" Menu \"MenuName\"{\n"
" Menu \"SubMenuName\"\n"
" {\n"
" Option \"OptionName\" \"Command\"\n"
" Option \"OptionName\" \"Command\" }\n"
" }Menu \"That bracket would be wrong since the line should end afterwards.\n"
" { //this would also be wrong\n"
"// Nothing should ever follow a bracket except a End Of Line character.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")