$re = '/^\h+[{}](?=\h*\R)(*SKIP)(*FAIL)|[{}]/m';
$str = ' Menu "MenuName"
{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command"
}
}
// This is a comment line
// [ curly brackets in comment lines are made square so they don\'t get counted as balancing
Menu "MenuName"{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command" }
}Menu "That bracket would be wrong since the line should end afterwards.
{ //this would also be wrong
// Nothing should ever follow a bracket except a End Of Line character.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);