using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\b\d+\b\s*";
string substitution = @"";
string input = @"1519 KINGSCROSS RD";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}