const regex = /\s*\b\d+\b\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\b\\d+\\b\\s*', 'g')
const str = `1519 KINGSCROSS RD`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);