#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/?([\w+-]+)\/?(?|\;[^\/]*|[?#].*)?$"
Local $sString = "edit" & @CRLF & _
"/edit" & @CRLF & _
"/edit/" & @CRLF & _
"/content/edit" & @CRLF & _
"/content/edit/" & @CRLF & _
"/content/edit;param=foo" & @CRLF & _
"/content;param=foo/edit/" & @CRLF & _
"/content/edit?q=foo" & @CRLF & _
"/content/edit/?q=foo" & @CRLF & _
"/content/edit#foo" & @CRLF & _
"/content/edit/#foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")