import re
regex = re.compile(r"\/?([\w+-]+)\/?(?|\;[^\/]*|[?#].*)?$", flags=re.MULTILINE)
test_str = ("edit\n"
"/edit\n"
"/edit/\n"
"/content/edit\n"
"/content/edit/\n"
"/content/edit;param=foo\n"
"/content;param=foo/edit/\n"
"/content/edit?q=foo\n"
"/content/edit/?q=foo\n"
"/content/edit#foo\n"
"/content/edit/#foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")