re = /\/?([\w+-]+)\/?(?|\;[^\/]*|[?#].*)?$/m
str = 'edit
/edit
/edit/
/content/edit
/content/edit/
/content/edit;param=foo
/content;param=foo/edit/
/content/edit?q=foo
/content/edit/?q=foo
/content/edit#foo
/content/edit/#foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end