use strict;
my $str = 'Well f*** you!
Well f***!
f***
f*** this!
secret code is 123f***
f**k this!
sh*t* not?
sh*t but this
f***a this not?
f***! but this
f**** this not?';
my $regex = qr/\b(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}