$re = '/\b(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])/m';
$str = 'Well f*** you!
Well f***!
f***
f*** this!
secret code is 123f***
f**k this!
sh*t* not?
sh*t but this
f***a this not?
f***! but this
f**** this not?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);