re = /\b(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])/m
str = 'Well f*** you!
Well f***!
f***
f*** this!
secret code is 123f***
f**k this!
sh*t* not?
sh*t but this
f***a this not?
f***! but this
f**** this not?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end