package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^UPLOAD\|(?'name'.+)\|(?'label'.*)\|(?'required'REQUIRED)?$`)
var str = `UPLOAD|d|dd|REQUIRED`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}