$re = '/^UPLOAD\|(?\'name\'.+)\|(?\'label\'.*)\|(?\'required\'REQUIRED)?$/m';
$str = 'UPLOAD|d|dd|REQUIRED';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);