using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""'](.*)[""']\s*?:\s*?[""'\[](.*)[""'\]]";
string input = @" ""The issue"": ""L'oggetto "",
""issue"": ""o\""ggetto"",
""issue"": 'oggetto ""novo"" ', ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}