$re = '/["\'](.*)["\']\s*?:\s*?["\'\[](.*)["\'\]]/';
$str = ' "The issue": "L\'oggetto ",
"issue": "o\\"ggetto",
"issue": \'oggetto "novo" \', ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);