import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{81})(?:\\w+[.-])*\\w{1,50}@\\w{1,25}(?:[.-]\\w+)*\\.\\w{2,3}$";
final String string = "test@test.com\n"
+ "12345678901234567890123456789012345678901234567890@1234567890123456789012345.com\n"
+ "test.test.test@1234567890123456789012345.com\n"
+ "test.test.test@12345678901234567890123456.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}