const regex = /^(?!.{81})(?:\w+[.-])*\w{1,50}@\w{1,25}(?:[.-]\w+)*\.\w{2,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.{81})(?:\\w+[.-])*\\w{1,50}@\\w{1,25}(?:[.-]\\w+)*\\.\\w{2,3}$', 'gm')
const str = `test@test.com
12345678901234567890123456789012345678901234567890@1234567890123456789012345.com
test.test.test@1234567890123456789012345.com
test.test.test@12345678901234567890123456.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}