$re = '/^(?!.{81})(?:\w+[.-])*\w{1,50}@\w{1,25}(?:[.-]\w+)*\.\w{2,3}$/m';
$str = 'test@test.com
12345678901234567890123456789012345678901234567890@1234567890123456789012345.com
test.test.test@1234567890123456789012345.com
test.test.test@12345678901234567890123456.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);